الرئيسية » Cisco » لأب عملي لربط شبكتان IPV6 من خلال شبكة تعمل على IPV4

لأب عملي لربط شبكتان IPV6 من خلال شبكة تعمل على IPV4

منذ فترة قصيرة طلب أحد الأصدقاء مساعدة على الفايس بوك حو مشكلة تواجه تتمثل في ربط شبكتان تعملان بالـ IPV6 من خلال الأنترنت والذي لازال يعمل حتى الآن إعتمادا على الـ IPV4 كما نعلم , وقد نفذت الحل وطرحته على الفايس بوك واليوم أطرحه على المدونة كنوع من الأرشفة ولكي يستفيد منه الجميع, سوف أضع نص السؤال كما كتبه صاحبه كونه يتحدث عن مقدمة مفيدة حول فكرة الـ Tuneling التى نعتمد عليها لتنفيذ الحل.

التقي بكم مجددا هذا اليوم ومع مشكلة جديدة والتي لم اجد لها حلا املا ان اجد الحل هنا … المشكلة هي في عملية الانتقال من الاصدار الرابع الى الاصدار السادس … IPv4 to IPv6 وكما اشرنا سابقا ً بأن يجب على المهندس ان يتعلم الاصدار الجديد حيث تقريبا تم تعديل جميع بروتوكولات التوجيه لتعمل على الاصدار الجديد … ونظرا ً لان عملية الانتقال من الاصدار القديم IPv4 الى الاصدار الجديد لن تتم في ليلة ويوم بل ستاخذ وقت ولانه يستحيل تغيير البنية التحتية للانترنت واقصد هنا بالبنية التحتية ( Internet Back Bone ) … وجدت ما تسمى بالــــــ Transitioning Methodology طرق الانتقال …. على رغم اختلاف الطرق للانتقال الا انها تتمحور جميعها حول مبدأ واحد وهو مبدأ الــــــــــ Tunneling …. دعني اوضح ماتعنيه كلمة Tunneling الــــ Tunneling يعني وجود قناة او نفق بالانترنت …. وحتى اكون دقيقا في التعبير النفق هو تغليف شئ بشئ …. مثلا الباكت من الاصدار السادس يغلف بباكت من الاصدار الرابع يعني يصير الـــ Header للاصدار السادس كانه بيانات لايعرفها ولا يفقهها الاصدار القديم … وهو الشئ الذاته الذي يحدث مع الــــ VPN … وهناك كثير من الطرق من بينها IPv6ip Manual Tunneling,اعطيكم المشكلة التي واجهتها منذ اسبوع … كالتالي :

توجد شبكتين تعملان بالاصدار السادس الاولى بصنعاء والثانية بنيويورك ….

Sana’a network : 2002:DB8:ACE:1::/64

New York Network: 2001:DB8:ACE:1::/64

وبينهم شبكة واحدة تعمل على الاصدار القديم الرابع IPV4

Network IPv4: 209.165.200.0/24

صورة اللاب.

1236595_708680675824262_1957424813_n

الأعدادت على التوالي:

Cisco's
R3: ipv6 unicast-routing
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:ACE:1::1/64
ipv6 rip 6bone enable
!
ipv6 router rip 6bone

Cisco's
R2: ipv6 unicast-routing
interface Tunnel0
no ip address
ipv6 address 12:12:12:1::1/64
ipv6 rip 6bone enable
tunnel source Serial0/0
tunnel destination 209.165.200.1
tunnel mode ipv6ip
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:DB8:ACE:1::2/64
ipv6 rip 6bone enable
!
interface Serial1/0
ip address 209.165.200.2 255.255.255.0
clock rate 64000
ipv6 router rip 6bone

Cisco's
R1: ipv6 unicast-routing
interface Tunnel0
no ip address
ipv6 address 12:12:12:1::2/64
ipv6 rip 6bone enable
tunnel source Serial0/0
tunnel destination 209.165.200.2
tunnel mode ipv6ip
!
interface Serial0/0
ip address 209.165.200.1 255.255.255.0
clock rate 64000
!
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 2002:DB8:ACE:1::2/64
ipv6 rip 6bone enable
!
ipv6 router rip 6bone

Cisco's
R4: ipv6 unicast-routing
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2002:DB8:ACE:1::1/64
ipv6 rip 6bone enable
!
ipv6 router rip 6bone

في الأعدادت أعتمد على بروتوكول الـ RIP في عملية التوجيه ولو في حال أردنا عمل Static Route يكفي أن نضيف الاوامر التالية للروتر لكي يعمل بشكل جميل.

Cisco's
R3: ipv6 route 2002:DB8:ACE:1::/64 2001:DB8:ACE:1::2
R2: ipv6 route 2002:DB8:ACE:1::/64 Tunnel0
R1: ipv6 route 2001:DB8:ACE:1::/64 Tunnel0
R4: ipv6 route 2001:DB8:ACE:1::/64 2002:DB8:ACE:1::2

ملاحظة: هناك أختلاف بسيط بين رقم الأيبي الموضح بالصورة والأعدادت.

أي ملاحظات أو أستفسارات حول اللاب لاتتردد في الطرح, اتمنى ان تستفيدوا من المعلومة ودمتم بود.

Print Friendly
منذ فترة قصيرة طلب أحد الأصدقاء مساعدة على الفايس بوك حو مشكلة تواجه تتمثل في ربط شبكتان تعملان بالـ IPV6 من خلال الأنترنت والذي لازال يعمل حتى الآن إعتمادا على الـ IPV4 كما نعلم , وقد نفذت الحل وطرحته على الفايس بوك واليوم أطرحه على المدونة كنوع من الأرشفة ولكي يستفيد منه الجميع, سوف أضع نص السؤال كما كتبه صاحبه كونه يتحدث عن مقدمة مفيدة حول فكرة الـ Tuneling التى نعتمد عليها لتنفيذ الحل. التقي بكم مجددا هذا اليوم ومع مشكلة جديدة والتي لم اجد لها حلا املا ان اجد الحل هنا ... المشكلة هي في عملية الانتقال من الاصدار…

عناصر المراجعه :

تقييم المستخدمون: 4.9 ( 1 أصوات)

عن Ayman Alnaimi أيمن النعيمي

مهندس كمبيوتر سوري ومقيم حاليا في قطر , باحث ومطور للمحتوى العربي على الأنترنت, أهدف إلى رفع مستوى الأمة العربية ومساعدتها في النهضة العلمية, أغلب أهتماماتي في الشبكات وتحديدا الهاردوير منها وأقضى معظم وقتي في القراءة والدراسة والعمل وأؤمن بأن الثورة لو كانت لتكون فهي تبدأ بالقراءة ويليها الكتابة وبدون الآخيرة لن يكون هناك ثورة. للتواصل admin@networkset.net & networkset@hotmail.com

7 تعليقات

  1. جزاك الله خيرا يا اخ ايمن، احب فقط ان اضيف امران لو امكن علي المثال الخاص بك اعتقد انها اخطاء سهو لا اكثر ولكن من الممكن ان تؤثر علي فهم الاعضاء:
    1- R2 -inter s0/0 وليست s1/0
    لانك وضعت الtunnel source s0/0
    2- للاضافه البسيطة … لقد استخدمت في مثالك
    ipv6 over ipv6ip Tunnel
    كما يمكننا ان نستخدم طريقه اخري وهي ال
    ipv6 over ipv4 GRE Tunnel
    وهو يكون بنفس الاوامر التي استخدمتها مع حذف فقط الامر
    #tunnel mode ipv6ip
    من R1 &R2 –inter tunnel 0
    وشكرا للمجهود

  2. الأول ليس خطأ, أنا نفذت اللاب على الـ GNS3 ولم أعتمد على الرسمة . أخذت الأعدادت وقارنتها بأرقام الروترات فقط. لاحظ ان لم أضع منافذ ايثرنت كما هو على الرسم بل وضعت فاست ايثرنت.
    ثانيا هذه طريقة وهذه طريقة والكل صحيح.
    شكرا لك.

  3. والله تحية لك علي مجهودك … لا اقصد الاساءة … فقط اردت ان اعطي للمهتم فكرة اخري لا أكثر

  4. آستاذ ايمن ممكن تنزل فيديو للشرح .. رح يكون افضل للفهم استاذي

  5. متشكر جدا

  6. يا استاد ايمن انا عندي مشروع ل اليات الانتقال الي ipv6
    نبي شرح وكيف نطبقه عملي

  7. شكرا ع موضوع .. طيب في حال بدي حول هالحكي لمشروع تخرج كيف بحسن اطبقو هل باستخدام معدات ip4 للااتصال ب اجهزه تعمل ip6 ارجو مساعده هي فكره كتير حلوه وبدي اجرب اعملا كمشروع تخرج بس ممكن مساعده بطريقه ربط افكار كمشروع تخرج هل يمكن ان استفيد في تنفيذها عن طريق برنامج باكت ريسير

اضف رد

لن يتم نشر البريد الإلكتروني . الحقول المطلوبة مشار لها بـ *

*

x

‎قد يُعجبك أيضاً

حل مشكلة error 27850 عند تنصيب Cisco VPN Client

مقال سريع لتوثيق مشكلة صادفتني وقمت بحلها بخطوتان وهي تنصيب برنامج سيسكو الخاص بالـ VPN ...

حل مشكلة الشاشة البيضاء في برنامج Cisco configuration Professional

كما هو معلوم لدى خبراء سيسكو أن الآخيرة أتاحت عدة أدوات مساعدة للقيام بعملية الأعدادت ...

مقارنة بين أنظمة سيسكو IOS و IOS-XR و IOS-XE و NX-OS

في هذا المقال سوف نتعرف سوياً على جميع الأنظمة التشغيلية التى قامت سيسكو بتطويرها وهي ...