الرئيسية » Network » الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان

الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان

الوصول والتحكم بالمايكروتك عن بعد ومن أي مكان

طلب الكثير من الاخوة شرح هذه الخاصية ورغم وجود الكثير من الطرق التي تعتمد على التسجيل في موقع اخر وانشاء دومين وكتابة اكواد معقدة والكثير الكثير من الطرق الطويلة ولكن اليوم وجدت طريقة مجربة ومختصرة أتمنى ان تنال رضاكم وتنطبق على كل أنواع الراوتر بورد الخاصة بالمايكروتك وكما يلي:

نفتح الون بوكس بشكل طبيعي ثم ننقر على تبويب (system) ونختار منه السكربت (script) وكما في الصورة التالية:

1

والان ننقر على زر انشاء سكربت جديد من علامة الزائد (+) وكما في الصورة التالية:

2

والان اتبع التعليمات في الصورة التالية:

3

واما السكربت الذي يتم نسخه ولصقه فهو كما في ادناه:

# Define User Variables

:global ddnsuser “southbird”

:global ddnspass “mothana”

:global ddnshost “00.00.00.00”

# Define Global Variables

:global ddnsip

:global ddnslastip

:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip “0” }

:global ddnsinterface

:global ddnssystem (“mt-” . [/system package get system version] )

# Define Local Variables

:local int

# Loop thru interfaces and look for ones containing

# default gateways without routing-marks

:foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={

:if ([:typeof [/ip route get $int routing-mark ]] != str ) do={

:global ddnsinterface [/ip route get $int interface] }

}

# Grab the current IP address on that interface.

:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

# Did we get an IP address to compare?

:if ([ :typeof $ddnsip ] = nil ) do={

:log info (“DDNS: No ip address present on ” . $ddnsinterface . “, please check.”)

} else={

:if ($ddnsip != $ddnslastip) do={

:log info “DDNS: Sending UPDATE!”

:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip “/”] ] key-name=$ddnsuser key=$ddnspass ] ] :global ddnslastip $ddnsip

} else={

:log info “DDNS: No update required.”

}

}

# End of script

طبعاً لا يجب ان تنسى تغيير اسم المستخدم وكلمة المرور وعنوان حساب ال DNS الخاص بك ولا ننسى في نهاية هذا الدرس ان نتقدم بالشكر الجزيل الى الأستاذ (مثنى الهاشمي) لتجربته هذه الطريقة واثبات نجاحها ويمكنكم الاتصال به لأي استفسار على عنوانه في الفيس بوك:

https://www.facebook.com/mothana.alhashmiy?fref=ufi

Print Friendly

عن مصطفى صادق

مصطفى صادق لطيف مهندس عراقي يهدف الى تعلم كل ما يخص شبكات الحاسوب ونشر كل ما يعرف لمن يريده ومن يطلبه بلا ثمن ولا هدف سوى المساهمة في اثراء الثقافة العربية في علم الحاسوب عموماً وشبكات الحاسوب خصوصاً ودفع الشباب العربي والنشء الجديد الى اكتساب العلم والمعرفة التي تؤهلنا الى اللحاق بركب من حولنا من الامم

18 تعليق

  1. عبدالله الجصاني

    شكرا استاذ مصطفى عندي استفسار كيف ادخل عليه من المكان الاخر

    • الاخ الكريم عبد الله
      بعد ان تكمل خطوات الدرس اعلاه تقوم بالذهاب الى اي مكان في العالم وتربط حاسوبك الشخصي على شبكته وتفتح الون بوكس وتكتب بداخله عنوان الراوتر بورد الذي ضبطت اعداداتك بداخله وتريد الوصول اليه من بعيد وتاكد انك تكتب العنوان الحقيقي (WAN Real IP) الخاص بشبكتك واسم المستخدم وكلمة المرور التي تستخدمها عادة للدخول من داخل الشبكة للراوتر وسيفتح لك واجهة الون بوكس الخاصة بشبكتك وان كنت متصل بشبكة اخرى وهذه هي الفكرة من الموضوع (الوصول عن بعد)
      شكراً للمتابعة والاهتمام

  2. عبدالله الجصاني

    شكرا استاذ مصطفى ربي يوفقك

  3. العفو اخي الكريم وبالتوفيق ان شاء الله

  4. طب ازااي ادخل عليه من الاندرويد … نفسي حد يفيدني في الحوار ده

  5. كيف يمكننى معرفة البيانات المطلوبة مثل WAN Real IP ماين يتم كتابتها

  6. يتم الحصول عليها من مزود الخدمة ويتم كتابتها في حسابك في ال OPEN DNS او ال DYNDNS ومنهم تأخذ اسم المستخدم وكلمة المرور (معلومات التسجيل) لتضيفها هنا في السطور الاولى كما موضح

  7. يوجد تطبيق للاندرويد اسمة mikro winbox.
    لاكن انا لم افهم ما هو البابلك، وكم يكون الايبي الخاص بالرواتر بورد ارجو الشرح والتوضيح.
    والشكر لكم,,,,,,,

  8. السلام عليكم استاذي الكريم هل من طرقة اخرى للتحكم بمستخدمي المكروتك عن بعد مثل ان تضع رابط http://www./////.com ويمكن للنستخدم الاطلاع على رصيده حت وان سجل الدخول من اي شبكة
    اذا كان لديك اي اطلاع عن هذه الفكرة ارجاء اخبار نا بها جزيت خيرا

  9. استاذ اكو طريقة من خلالها اقدر ادخل من المايكروتك للاجهزة المتصله بيه والي هيه بالاكثر من شركة ubnt

  10. يا باشا انا مش علرف مكان اسم المستخدم وكلمة المرور وعنوان حساب ال DNS فى هذا الكود اعمل اية

  11. اخي العزيز اريد معرفة كيف تغيرر اسم المستخدم والرقم السري لم افهم النقطة الاخيرره

  12. استاذي العزيز كل الخطوات الي شرحتها فهمتها كلها بس مافهمت كلمة البابلك الخاصه بك ايش تقصد عل تقصد اكلود المايكروتك الخاص بي او الموقع الي ان مسجل فيه dns مثلا no-ipممكن الرد

  13. اخي الكريم ممكن عنوان الايبي او طريقة للدخول لل وينبوكس بدون برنامج

اضف رد

لن يتم نشر البريد الإلكتروني . الحقول المطلوبة مشار لها بـ *

*

x

‎قد يُعجبك أيضاً

VPNمجاني باستخدام برنامج الـ Team Viewer

أصبح برنامج team Viewer عصب عمل أغلب مهندسي الكمبيوتر وأصبح الاعتماد عليه كبير في عمليات ...

هل لدي Loop في الشبكة ؟

اليوم قصدت أحد الشركات التى أتصلت بي بسبب مشكلة في أجهزة الشركة جميعها وهي تقريبا ...

الجيل الخامس من تقنية البلوتوث Bluetooth 5.0

تعتبر الـ IoT أو الـ Internet of Things أحد التراندات العالمية والتى سوف تشهد طلب ...