الرئيسية » Cisco » كيفية أعداد الـ HSRP بالتفصيل

كيفية أعداد الـ HSRP بالتفصيل

 

أريد اليوم أن أحدثكم عن أحد البروتوكولات الهامة والتى يجب على كل مهندس شبكات أن يعرفها ويعرف طريقة أعدادها وهو HSRP كما أنا هذا البروتوكول هو من أكثر الأسئلة شيوعا في المقابلات الشخصية لذا أحرص أن تكون ملم بشكل جيد بهذا البروتوكول

ماهو الـ HSRP ؟

معناها Hot Standby Router Protocol وهو بروتوكول قامت سيسكو بتطويره أول مرة ووظيفته توفير Gateway بديل أو أحتياطي للشبكة في حال حدوث أي مشكلة مع الروتر ولنفهم الموضوع بشكل أكبر سوف أعرض عليكم هذه التبلوجي

كما نشاهد في التبلوجي يملك جهاز الكمبيوتر PC3 ثلاث طرق للوصول إلى الهدف وهو هنا R4 وطبعا سوف نقوم نحن بتحديد الـ GateWay للجهاز بأنفسنا ليستخدم أحد الثلاث روترات الموجودة وقد قمت بأختيار الروتر 1 ليكون هو الروتر الـ Default للشبكة لكن السؤال الآن ماذا لو توقف الروتر واحد عن العمل ماذا سوف يحدث ؟ والأجابة طبعا سوف تتوقف كل الشبكة عن العمل ومن هنا اتت فكرة HSRP

تقوم فكرة الـ HSRP على توفير أكثر من طريق للشبكة للوصول إلى الهدف وذلك بأعطاء الثلاث روترات الموجودة ايبي وماك أدريس وهمي واحد  سوف يكونوا الـ Default GateWay  ولو تعطل الروتر الثاني سوف يقوم الروتر رقم 3 بتمرير الترافيك إلى R4 وطبعا هذا كله يتم من دون ان يحس المستخدم بأي شيء وبكلام آخر تقوم هذه التقنية بعمل روتر وهمي يملك بورت واحد وهو الـGateway للشبكة وطبعا هذا البورت يملك ايبي وماك أدرس يفهمها المستخدم على أنها هي الـGateway للشبكة ولكن في الحقيقة هي عبارة عن ثلاث روترات يشرف أحدها على تمرير الترافيك ولو في حال حدوث مشكلة في هذا الروتر تقوم هذه التقنية بشكل اوتماتيكي بتحويل الترافيك إلى الروتر الثاني وهكذا

طريقة الأعداد

قبل أن ابدا طريقة الأعداد على الروترات أحب ان أونوه ان جهاز الكمبيوتر الموجود في التبلوجي يملك الأيبي 192.168.1.2/24 و gateway  192.168.1.1 والآن نتوجه إلى الروتر رقم واحد وندخل على البورت المتصل مع الشبكة وهو هنا Ethernet 0/0 ونقوم بمايلي

Cisco's IOS

interface Ethernet0/0
ip address 192.168.1.3  255.255.255.0
no shutdown
standby 1 preempt
standby 1 ip 192.168.1.1

بعد أن قمت بأعطاء البورت أيبي وقمت بتفعيله نبدأ مرحلة اعداد الـ HSRP من خلال كلمة Stanby وبعدها أختار رقم المجموعة أو الـ Group التى سوف تجمع الثلاث روترات مع بعضها البعض وبعدها أضيف كبمة Preempt وهي مهمة ومفيدة جدا في حال تعطل الروتر الأول وأستلم الروتر الثاني دفة الأمور وبعد كم دقيقة عاد الروتر الأول للعمل عندها لن يستلم الروتر الأول دفة الامور إلا بحال تعطل الروتر الثاني لذا نضيف هذه الكلمة لتفهم المجموعة في حال عاد الروتر الاول للعمل فيجب أن يستلم دفة الأمور بشكل مباشر

وآخيرا اقوم بكتابة الأيبي الوهمي للشبكة والذي سوف يكون الـ default Gatway للشبكة

نتوجه إلى الروتر الثاني ونقوم بنفس الأعدادات مع تغيير بسيط وكما يلي

Cisco's IOS

interface Ethernet0/0
ip address 192.168.1.4  255.255.255.0
no shutdown
standby 1 priority 95
standby 1 ip 192.168.1.1

التغيير الذي قمت بعمله في الروتر الثاني هو أضافة الأمر priority 95 وهو مهم في تحديد الأفضلية بين الروترات وهو by default 100  لذا قمت بكتابة الرقم 95 في الروتر الثاني لكي يكون هو الروتر الثاني بعد تعطل الروتر الأول والذي يملك الأفضلية 100كما أوضحت مسبقا

أعداد الروتر الثالث نفس الثاني لكن مع اختلاف قيمة الـ Priority  وهي كما يلي

Cisco's IOS

interface Ethernet0/0
ip address 192.168.1.4  255.255.255.0
no shutdown
standby 1 priority 90
standby 1 ip 192.168.1.1

وتتم عملية التحويل من روتر لآخر من خلال أرسال hello message بين  الروترات الموجودة في المجموعة كما يمكننا مراقبة المخرج الثاني للروتر والذي يتصل مع الروتر 4  من خلال مراقبة حالت البورت هل هي UP أم Down لان اذا تعطل سوف يتوقف العمل أيضا على الشبكة لذا نلجأ ايضا إلى مراقبته من خلال أضافة الأمر التالي

Cisco's IOS
standby 1 track Ethernet 0/2

وكنوع من الأمن ضع كلمة سر بين الروترات الموجودة في المجموعة من خلال الأمر التالي

Cisco's IOS
standby 1 authentication password

وطبعا نضع كلمة سر في مكان Password ولعرض حالة البروتوكول على الروتر نستخدم الامر show standby  وأرجو أن تلاحظ كلمة Active والتى تعني أن هذا الروتر هو الذي يقوم بعملية تمرير البيانات بينما كلمة standby  تدل على الروتر هو الثاني في قائمة الأفضلية او الأحتياطي الأول وكلمة listen تدل على الأحتياطي الثاني

لنقم الأن بعملية تتبع من الجهاز الموجود على الشبكة لنرى مع أي المخارج يتصل الجهاز وهي موضحة بالصورة التالية

ونشاهد أن الوصول للهدف يتم من خلال الايبي 192.168.1.3   وهو الروتر الأول وللتأكد من الأمر قم باغلاق البورت على الروتر الأول وقم بعملية التتبع لتشاهد ان الأيبي سوف يتحول إلى الايبي192.168.1.4 أي الروتر الثاني

كلمة آخيرة كما أوضحت ان هذا البروتوكول سيسكو قامت بتطويره لذا لن يعمل إلا على اجهزتها ولتطبيق هذا الأمر على روترات آخرى نلجأ إلى بروتوكول آخر يدعى VRRP وهو يقوم بنفس العملية ويصلح لجميع أنواع الروترات ولأعداداه قم بأستبدال كلمة HSRP بي VRRP ودمتم بود

Print Friendly, PDF & Email

عن Ayman Alnaimi أيمن النعيمي

مهندس كمبيوتر سوري ومقيم حاليا في قطر , باحث ومطور للمحتوى العربي على الأنترنت, أهدف إلى رفع مستوى الأمة العربية ومساعدتها في النهضة العلمية, أغلب أهتماماتي في الشبكات وتحديدا الهاردوير منها وأقضى معظم وقتي في القراءة والدراسة والعمل وأؤمن بأن الثورة لو كانت لتكون فهي تبدأ بالقراءة ويليها الكتابة وبدون الآخيرة لن يكون هناك ثورة. للتواصل admin@networkset.net & networkset@hotmail.com

16 تعليق

  1. جزاك الله خيرا استاذ ايمن موضوع ممتاز كالعادة

  2. جزاك الله خير
    اشكرك ع التنويه على اهمية هذا البرتوكول

  3. محب الشبكات

    كيف ممكن أن أطبقه على الgns3
    لأني ملاحظ أنك مستخدم سويتش ومعروف أن السويتش لايعمل في الgns3
    ماهي الإعدادات التي قمت بها غير التي على الراوتر لكي يعمل هذا البروتوكول

  4. السويتش الذي قمت بأضافته هو سويتش عادي ولايوجد له موجه اوامر أو أي أعدادات باستثاء رقم البورت بحسب ما أذكر تستطيع أن تجده في الخانة اليسرى في البرنامج
    وهذه كل الأعدادات التى قمت بها ولا يوجد أي شيء آخر
    وشكر للجميع على المرور 😉

  5. شكرا اخي وجزاء الله الف خير

  6. جزاك الله خيرا اخى ايمن 🙂

  7. ممتاز شكرا وجاري تنفيد الاب الممتع يعطيك العافية

  8. جزاك الله كل كل خير وربنا يكرمك ويجعلك سبب من اسباب الوصول لاهدافنا وربنا يزيدك علم…

  9. assalamu 3alaykom dear i think that VRRP and HSRP are differente i have use VRRP for redundancy between 2 routers but HSRP i have use it betweeen 2 Firewall to make redundancy for TCP/UDP connection waiting for your feedback wajazakoma llaho khayran

  10. كبير يا بش مهندس كبيييييييييييييييييير شرح رائع …

  11. السلام عليكم ورحمه الله وبركاته
    جزاك الله خير م.ايمن وكثر الله من امثالك.
    أستمر فأنت مبدع.

  12. جزاك الله عنا كل الجزاء. شرح مبسط وميسر ارجو المواصلة في كل المواضيع المتعلقة بشهادة CCNP

  13. شكرا جداااا على الشرح اللى فوق الرائع و ربنا يكرمك و ييسر امرك

  14. بعد اذن حضارتكو عندى سؤال ازاى ال ip الخاص بالراوتر الثالث نفس ال ip الخاص الراوتر الثانى 192.168.1.4

    مكتوب فوق كدة
    أعداد الروتر الثالث نفس الثاني لكن مع اختلاف قيمة الـ Priority وهي كما يلي

    interface Ethernet0/0
    ip address 192.168.1.4 255.255.255.0
    no shutdown
    standby 1 priority 90

  15. شكرا لك اخي لكن هذا البروتوكول خاص في اجهزة سيسكو فقط السؤال : هل هناك بديل لهذا البروتوكول اذا لدي راوتر سيسكو متصل براوتر لشركة اخرى مثل جنيفر ؟ اذا موجود يرجى التوضيح

أضف رد على اسامة إلغاء الرد

لن يتم نشر البريد الإلكتروني . الحقول المطلوبة مشار لها بـ *

*

x

‎قد يُعجبك أيضاً

حل مشكلة error 27850 عند تنصيب Cisco VPN Client

مقال سريع لتوثيق مشكلة صادفتني وقمت بحلها بخطوتان وهي تنصيب برنامج سيسكو الخاص بالـ VPN ...

حل مشكلة الشاشة البيضاء في برنامج Cisco configuration Professional

كما هو معلوم لدى خبراء سيسكو أن الآخيرة أتاحت عدة أدوات مساعدة للقيام بعملية الأعدادت ...

مقارنة بين أنظمة سيسكو IOS و IOS-XR و IOS-XE و NX-OS

في هذا المقال سوف نتعرف سوياً على جميع الأنظمة التشغيلية التى قامت سيسكو بتطويرها وهي ...