الرئيسية » Cisco » خمس أشياء يجب أن تعرفها عن سوتشات سيسكو

خمس أشياء يجب أن تعرفها عن سوتشات سيسكو

في أغلب الأحيان تكون استخدامتنا للسويتش على مستوى بسيط  في البيت أو شركة صغيرة أو مدرسة الخ….وعادة تكون هذه السويتشات من نوع plug and play يعني نقوم بتوصيل الأجهزة وأنتهى عمل السويتش بحيث لايمكننا أعداد أو تغيير أي شيء على السويتش ولاحتى أصلاح الأعطال أن وجدت ومن هنا قد يفكر أحدنا بشراء سويتشات أفضل من حيث الأداء والتحكم مثل سويتشات سيسكو والتى سوف أخصها بهذه التدوينة وهي طبعا للمبتدئين في عالم سيسكو

وللذين لايملكون أي خبرة في التعامل مع هذا النوع من الاجهزة  لذا أحببت أن أطرح في هذا التدوينة الأشياء الخمسة التى يجب أن تعرفها حول هذا النوع من أجهزة سيسكو بغض النظر عن خبرتك في التعامل معها

الشيء اأول : ماهو الـVlan وماهو الـDefault Vlan ؟

الـVlan أو Virtual Lan هي خاصية تسمح لنا بعزل المنافذ عن بعضها البعض على شكل مجموعات والتى تعطي للشبكة شيئان مهمان الأول هو الأداء الأفضل للشبكة فمن خلال عزل هذه البورتات عن بعضها سوف نقوم أيضا بعزل الـBroadcast أيضا عن المنافذ بحيث لو خرج broadcast من أحد مجموعات الـVlan فسوف يقتصر فقط على هذه المجموعة ولن ينتشر على كل المنافذ والشيء الثاني وهو الأمن والسكيورتي فهي تتيح لنا عزل الأشخاص تماما عن بعضهم وبالتالي هذا يؤمن سرية وحماية أكبر للمستخدمين الموجودين على الشبكة أما الـ Default Vlan فهي عادة Vlan1 وهي عادة تضم كل المنافذ الموجودة على السويتش ونستطيع مشاهدتها من خلال كتابة الأـمر Show vlan كما في الشكل التالي

الشيء الثاني : لماذا أعطي السويتش أيبي ؟

كما هو معروف عن السويتشات الخاصة بالطبقة الثانية data link بأن تعاملها مع الترافيك يتم من خلال الماك أدريس فقط لكن مع سويتشات سيسكو هناك أمكانية أعطاء السويتش أيبي لهدف واحد فقط وهو من أجل إتاحة التحكم بالسويتش عن بعد مثل أستخدام التلنت أو الـ SSH وهي تتم من خلال أعطاء الـVlan أيبي ومن خلال الأوامر الموضحة معنا بالصورة التالية

Cisco's IOS

Switch(config)# interface vlan1

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

الشيء الثالث : كيف أجعل البورتات تعمل بشكل أسرع ؟

تقوم سويتشات سيسكو بعدة أمور وأشياء قبل تفعيل المنفذ لكي يعمل وهي عادة تكون من أجل التأكد من عدم وجود loop في الشبكة لهذا نلجأ إلى عمل بعض الأعدادات لكي يقوم السويتش مباشرة بتفعيل المنفذ وهذه الأعدادات يجب أن تكون على البورتات المتصلة مع أجهزة كمبيوتر أو سيرفرات وهي كالتالي

Cisco's IOS

Switch(config)# interface FastEthernet0/1

Switch(config-if)# switchport mode access

Switch(config-if)# no shutdown

Switch(config-if)# spanning-tree portfast

الشيء الرابع : التحكم في سرعة المنفذ والـ Duplex ؟

يعد موضوع التحكم في سرعة المنفذ وأعداد الـ Duplex من أكثر الأشياء التى قد تؤدي إلى حدوث مشاكل في هذا النوع من الأجهزة بسبب وجود تعارض بين أعدادات المنفذ الموجود على السويتش وأعدادات المنفذ الخاص بجهاز الكمبيوتر المتصل معه لهذا نستخدم الأمر show interface متبوعا بنوع ورقم المنفذ من أجل التأكد من مطابقة الأثنان مع بعضهما البعض وهذا مثال يوضح كيف سوف تظهر النتائج

ويتضح لنا أن سرعة المنفذهي 100 وان حالة الـ Duplex هي Half ولو في حال اردنا تغيير هذه  الأعدادات مثل تغيير سرعة منفذ واحد غيغا إلى 100 وتغيير حالة الـ Duplex إلى Full نقوم بتنفيذ الأوامر التالية

Cisco's IOS

Switch(config)# interface gigabitEthernet 1/0

Switch(config-if)# speed 100

Switch(config-if)# duplex full

الشيء الخامس : كيف أزيد من الأمن والحماية للمنافذ المستخدمة؟

تدعم أغلب أجهزة سيسكو خاصية جميلة وهامة تدعى الـ Port Security وهي تسمح لنا بالتحكم في عدد الأجهزة التى يجب أن تعبر من خلال هذا المنفذ ( في حال لو كان هذا المنفذ مرتبط مع هوب مثلا) بالأضافة إلى أنها تسمح لنا بتحديد رقم الماك أدريس الذي يملك الصلاحية في العبور ولأعدادها يجب أن نتوجه إلى كل بورت ونقوم بتنفيذ الأعدادات التالية

Cisco's IOS

Switch(config)# interface fastethernet 0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport port-security

بتفعيلنا لهذه الخاصية نخبر السويتش بأن عدد الأجهزة المتاحة للعبور هي واحد فقط وهو أول ماك أدريس يعبر من خلال هذا المنفذ وهذا طبعا يساهم في حماية السويتش والشبكة من الأختراق أو التجسس أتمنى أن تكون هذه التدوينة قد قربت للمبتدئين في عالم سيسكو بعض المفاهيم الهامة في سويتشات سيسكو ودمتم بود  .

Print Friendly, PDF & Email

عن Ayman Alnaimi أيمن النعيمي

مهندس كمبيوتر سوري ومقيم حاليا في قطر , باحث ومطور للمحتوى العربي على الأنترنت, أهدف إلى رفع مستوى الأمة العربية ومساعدتها في النهضة العلمية, أغلب أهتماماتي في الشبكات وتحديدا الهاردوير منها وأقضى معظم وقتي في القراءة والدراسة والعمل وأؤمن بأن الثورة لو كانت لتكون فهي تبدأ بالقراءة ويليها الكتابة وبدون الآخيرة لن يكون هناك ثورة. للتواصل admin@networkset.net & networkset@hotmail.com

21 تعليق

  1. جزاك الله خير درس افادني كثير ..

  2. يسلمو هالديات مهندس ايمن..وبصراحه اغلب الاتاكينق يحدث من خلال السويتش..

    وبالطرق الي ذكرتها سويت لميت بشكل كبير لاغلب الهجوم الممكن حدوثه..

    تحياتي

  3. السلام عليكم

    جزاك الله خير على هذي المعلومات المبسطه و الطرح السهل و الى الامام يا اخي وعقبال ما نشوفك CCIE ان شاء الله عما قريب

    لي تعليق على سرعة المنفذ في الصورة واضح انه Half وفي شرحك تقول انه full وتشرح كيف تغيريه الى half فقط ملاحظه كي تكتمل الصورة الجميلة لهذا الموقع

  4. تمام أخي العزيز وشكرا على التنبيه 😉

  5. شكرا لك

  6. spanning-tree portfast

    من فضلك role de cette commande

    thank you

  7. جزاك الله خير اخي ايمن

  8. الف شكر ، بصراحة موضوع مفيد جداً ونا فهت منه VLAN أكثر الآن

  9. السلام عليكم و رحمة الله تعالى و بركاته
    جزاكم الله كل خير على كل ماتقومون به و جعله في ميزان حسناتكم
    🙂 🙂

  10. الله يعطيكون العافية يا رب و ياريت لو تعطينا كمان اساسيات الراوتر تبع سيسكو و بكون من الشاكرين و الف الف شكر ع هالموضوع الراائع فعلاً هي اهم شغلات بسيسكو

  11. to prevent looping in case connect another switch administrator has been disable STP on it
    Sw(config)#spanning-tree portfast bpduguard default
    sorry for using english :roll 🙄
    my keyboard doesn’t support arabic

  12. الله يعطيك العافيه
    اكثر من رائع

  13. هارون عبد الحليم

    والله انا اسعد واحد بكل مقاله تنشر في هذا الموقع اللي بافتخر ان شاب عربي اسسه وشباب عربيه دعمتو وا جوك لا تهتز من قله التفاعل فهذا حالنا نحن العرب ندخل فناخذ ما نريد ثم نخرج دون ان يشعر بنا احد
    فان كانت غايتك الله ثم رفعه الامه فاستمر انت وزملااك
    والي الامام دااما عذرا مش لاقي الهمزه التابلت
    وايك ان تياس او تترك الموقع او المجله
    فوالله ما فرحت بشاب كما فرحت بك وما سعدت بمقال واثر في كما تفعل مقالاتك
    وان شاا الله سانهي دراستي للccna وسابدا في المشاركه معكم حتي اشعر بوجودي
    لك وكل من معك كل التحيه والتقدير والاحترام والعاا بدوام التفوق
    اللهم اجعل هذا في ميزان حسناته بقدر نواياه
    واغفر لابيه وامه
    بقدر حبه لهما
    وارضي عنه رضاك عن ابي بكر

    هو وكل من عاونه
    واجعلني عونا له

  14. انور الاحدب

    السويتشات الزرقاء في الصورة التي الي اليمين هي سويتشات Extreme Networks

    ^_^

  15. شكرا جزيلا على الدرس و المعلومات المفيدة جزاك الله خيرا

  16. برمجة السويتشس اريد من فضلك كفيفة برمجة السويتشس من ا الى ي وكيفية وضع رقم سري في البرمجة

  17. الله يعطيكم العافيه

  18. السلام عليكم …

    اقدر اربط اكثر من سويتش مع بعض وتوصيل الراوتر مع احد هالسويتشات بدون الحاجه لربط الراوتر مع سويتش اخر ؟

    ام اربط كل سويتش مع الراوتر ؟

  19. شكر اً لك بس لي سؤال
    انا عملت شبكه فايبر mutli mode ولما وصلت ما اشتغل الجيبك وقمت بتبديله اكثر من مره مره يشتغل ومره لا والان ما اشتغل مع العلم انه السوييش جديد والفايبر شغال تم فحصه ولكن ما يخرج الفايبر من برا السويش

  20. لازلت بانتظار رد حل لمشكلة عدم خروج الفايبر من خارج السويتش مع العلم ان السويش جديد ولكن هل كل الجيبل واحد ام هنا ك جيبك معين لازم اشغتل فيه
    مع الشكر

  21. شكرا عالمعلومات المفيدة ممكن ايضا معلومات عن كيفية ربط port و ether وبرمجتها بالكومبيوتر

اضف رد

لن يتم نشر البريد الإلكتروني . الحقول المطلوبة مشار لها بـ *

*

x

‎قد يُعجبك أيضاً

حل مشكلة error 27850 عند تنصيب Cisco VPN Client

مقال سريع لتوثيق مشكلة صادفتني وقمت بحلها بخطوتان وهي تنصيب برنامج سيسكو الخاص بالـ VPN ...

مقارنة بين أنظمة سيسكو IOS و IOS-XR و IOS-XE و NX-OS

في هذا المقال سوف نتعرف سوياً على جميع الأنظمة التشغيلية التى قامت سيسكو بتطويرها وهي ...

VPNمجاني باستخدام برنامج الـ Team Viewer

أصبح برنامج team Viewer عصب عمل أغلب مهندسي الكمبيوتر وأصبح الاعتماد عليه كبير في عمليات ...