الرئيسية » Cisco » بعض الطرق الأحترافية في حجب المواقع

بعض الطرق الأحترافية في حجب المواقع

 

منذ فترة طويلة نوعا ما دار نقاش على منتدى عرب هاردوير حول أفضل طريقة لحجب موقع ما عن طريق أجهزة سيسكو وحينها وضعت ثلاث نقاط يمكن الأعتماد عليها لحل هذه المشكلة وأضعها اليوم على المدونة بسبب كثرة الطلبات على هذا النوع من الأسئلة ولاني تعبت كل مرة من البحث عن الموضوع في صفحات المنتدى

صاحب الموضوع أراد حجب موقع الـ You Tube عن الشركة وطلب حلا أعتمادا على الهاردوير ومن خلال الروتر وكان ردي حينها على الشكل الآتي

لو وضعت في مثل هذا الموقف لكنت أبتعدت عن سيسكو لحل هذه المشكلة كنت أولا أعتمدت على حلول مايكروسوفت وخصوصا لو كان هناك دومين للشبكة فببساطة سوف أقوم بالتعديل على ملف الـ Host الموجود في كل أنظمة مايكروسوفت على المسار التالي c:windowssytem32driversetc وأقوم بأضافة السطر التالي إليه

Host
127.0.0.1 www.youtube.com

وظيفة هذا الملف هو عمل Mapping بين الأيبي وأسم الموقع لكن بشكل يدوي يعني تستطيع أن تقول عنه DNS Static وبالتالي أي طلب لهذا الموقع(You tube) سوف يتم تحويله إلى 127.0.0.1 لان أول مكان يلجأ إليه الجهاز لمعرفة الأيبي والقيام بعملية الترجمة من أسم إلى أيبي هو ملف الهوست فأن لم يجد طلبه أرسل إلى الـ DNS Server وبالتالي منعنا المستخدمين من الوصول إلى موقع اليوتيوب تماما وخصوصا لو كانت الصلاحيات المعطاة لهم على الأجهزة هي صلاحيات User أما لو كان الجميع يملك صلاحيات administrator ولديهم خبرة جيدة مع أنظمة مايكروسوفت عندها يتوجب علينا تنصيب أيزا سيرفر وعمل Role تمنع الدخول إلى الموقع وإذا لم يكن لدينا ايزا سيرفر نتجه إلى سيسكو

الحل الأول الذي أقترحه على أجهزة سيسكو هو من خلال الـ policy-map وهذه هي الأوامر اللازمة

Cisco's
Router>en
Router#conf t
Router(config)#class-map match-any YouTube_Request
Router(config-cmap)#match protocol http host www.youtube.com
Router(config-cmap)#exit
Router(config)#policy-map Block_YouTube
Router(config-pmap)#class YouTube_Request
Router(config-pmap-c)#drop
Router(config-pmap-c)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#service-policy output Block_YouTube
Router(config-if)#end

طبعا الـ FastEthernet0/0 فرضته المنفذ المتصل مع لأنترنت

أما الحل الثاني فهو اللجوء إلى الأكسس ليست

Cisco's
Router>en
Router#conf t
Router(config)#access-list 101 deny tcp any host www.youtube.com eq 80
Router(config)#access-list 101 permit ip any any
Router(config)#interface FastEthernet0/0
Router(config-if)#ip access-group 101 out
Router(config-if)#end

هذا هو مجمل الرد الذي كتبته في ذلك الحين وقمت بأضافة فقرة الأيزا سيرفر كحل آخر للقيام بهذه المهمة هذا مالدي لكم اليوم أتمنى أن تكونوا قد استفدتوا من هذا الطرح ودمتم بود

Print Friendly, PDF & Email

عن Ayman Alnaimi أيمن النعيمي

مهندس كمبيوتر سوري ومقيم حاليا في قطر , باحث ومطور للمحتوى العربي على الأنترنت, أهدف إلى رفع مستوى الأمة العربية ومساعدتها في النهضة العلمية, أغلب أهتماماتي في الشبكات وتحديدا الهاردوير منها وأقضى معظم وقتي في القراءة والدراسة والعمل وأؤمن بأن الثورة لو كانت لتكون فهي تبدأ بالقراءة ويليها الكتابة وبدون الآخيرة لن يكون هناك ثورة. للتواصل admin@networkset.net & networkset@hotmail.com

31 تعليق

  1. يعطيك العافية اخ ايمن والله انه شرح ممتاز

  2. ماذا لو كان اسم الموقع يشير الى اكثر من عنوان انترنت، سيتم حجب العنوان الذي اختاره الراوتر فقط!!!

  3. جزاك الله خيرا ….

  4. بارك الله فيك !@!@!@!@!@!@!@!@!@

  5. You are a Professional

    Thanks a lot

  6. وماذا عن الجدار الناري iptables في لينكس !!
    اعتقد يفي بالغرض لو كان السيرفر خادم لينكس.

  7. طيب لو عملت حجب على موقع فيس بووك وكتبت العنوان هكذا http://www.facebook.com ونجحت العملية ولم يفتح الموقع لكن الموقع فتح لما كتبت facebook.com بدون www وايضا الموقع فتح لما فتحته من جوجل يعني كتبت facebook في جوجل ثم فتحت اول نتيجة بحث ففتح الموقع !!
    فاظطريت الى ان اكتب كل هذه القائمة بالحجب والحل ناجح
    http://www.facebook.com
    facebook.com
    *facebook.com
    لكن بالمناسبة هل يوجد حل آخر !!
    وشكرا

  8. الله يعطيك العافية استاذنا . . .

  9. شكرا ايمن…
    أعتقد أن الايزا 2006 افضل وأسهل حل لحجب الكثير من المواقع…

  10. بو عبدالرحمن
    السلام عليكم

    اعتقد انك بدل ما تكتب
    match-any
    اكتب
    match-all
    وان شاء الله تنحل معك
    طبعا مع انتظار رد البشمهندس ايمن
    شاكرين له الجهد العالي والعلم
    الذي نستمده منه
    فشكرا جدا يا بشمهندس ايمن وجزاك الله خير

  11. السلام عليكم
    اكيد استفدنا اخي الكريم
    هل تتكرم من فضلك وتخبرنا عن حل بسيط وسريع باستعمال نظام لينوكس لو امكن ذلك
    وشكرا

  12. شكرا لك اخوي ايمن

    وانا اوافقك الراي بانه الحل لدى مايكروسوفت اسهل واامن

  13. أفضل طريقة لسيرفرات سيسكو الأكسس ليست و أفضل طريقة لسيرفرات مايكروسوفت أكيد Isa server 2006 أو Forefront 2010

  14. 🙄 How to stop service for some and allow for some?
    in same vlan

    Please reply

  15. كيف اوقف الخدمة لبعض المستخدمين وبعضهم لا اوقفها لنفس vlan

  16. أولا شكرا للجميع وأنا الحقيقة سعيد جدا أن بدأت ارى مداخلات وتفاعل أكبر مع المواضيع 😛
    أحمد==>لم أفهم فكرتك أو ماتريد ايصاله ؟ فنحن عندما نطلب أيبي موقع من سيرفر الـ DNS فهو يرد علينا بأيبي واحد وليس بأكثر من أيبي ❗
    بوعبدالرحمن==> أكيد أخي أي جدار ناري يفي بهذه المهمة. وبالنسبة لسؤالك أنا أفضل أن تجرب بنفسك وسوف تكتشف الحل.
    عبدالله العريمي==> أكيد أخي وبالأخص أن يوجد سهولة بالتحكم والأدارة
    احمد امين==> لا أخي هذه الأوامر تفيد لو في حال هناك أكثر من match في الـ Map وفي مثالنا هناك match واحدة لذلك لن يكون هناك أي فرق.
    Ayoub==>الحلول كثيرة جدا وأي جدار ناري يفي بالغرض وتستطيع ايضا اللجوء إلى فكرة ملف الـ Host وسوف يكون في المستقبل حديث لي عن بعض أنواع الجدران النارية على لينوكس.
    Mohammed Alsharabi==> الأكسس ليست أخي

  17. عندما تطلب أيبي موقع من سيرفر ال DNS فانه يرجع أكثر من أيبي. مثلاً موقع يو تيوب:

    Non-authoritative answer:
    Name: youtube.com
    Addresses: 74.125.95.93
    74.125.47.93
    74.125.127.93

    فالنظام يختار أيبي من هذه الايبيات للاتصال معه

  18. السلام عليكم
    يا بشمهندس ايمن
    انا درست ان
    ال match-any تمنع على حسب الاسم او الرقم سواء port او ip

    وال match-all تمنع على حسب الاسم والرقم معا

    يعني مثلا لو ال msn شغال على port رقم 80
    وانت عايز تمنعه وتخلي ال explorer
    تستخدم match-any

    ولكن لو كتبت match-all
    في ال msn وال explorer مش هيشتغل
    لان اسمهم مختلف ولكن لهم نفس ال port

    هذا الانا فاهمه
    اتمنى تصحيح الخطأ في فهمي
    شاكر لك على كل مجهود وموضوع
    تتضح فيه المواضيع وتداخلها

  19. كلامك صحيح بس انت لا تخصص الامر وتقول أيبي وبورت وتجعلهم شروط للـ match all and any الفرق الجوهري هو كما ذكرته لكن بدون تخصيص أو تعيين يعني لما تريد تقديم الفرق تستطيع أن تقول الـ match all تحتاج إلى تطبيق كل الشروط الموجودة في الـmap بينما الـ match any يكفيها شرط واحد لتفعيل البوليسي لذلك انا قلت من البداية ان تغيير الـ map إلى match all لن يغير شيء لان عدد الشروط أو الـ match هي واحدة فقط ولن ينفع التغيير مها شيء أما لو كان لدينا أكثر من شرط عندها ممكن يؤثر التغيير فيها البوليسي.

  20. هلا أخي أيمن

    هل يمكن أن نشترك معك بمواضيع وحلول في مدونتك وكيف …

    • المشاركة الآن مقتصرة على المجلة وقريبا سوف تكون المدونة للجميع
      تحياتي وبأنتظار مقالك معنا على المجلة

  21. شكرا جدا يا بشمهندس
    جعله الله في ميزان حسناتك
    مدوتك اكثر من روعه

  22. يعطيك ألف عافية

  23. ❓ سلمت يداك يااخي على المدونة واتمنى منك اغنائها بالشرح المفصل وبالفيديوهات المرثية ليزداد الشرح وضوحا

  24. بسم رالله ما شاء الله
    عجبتني الفكرة
    ما شاء الله مدونتك صارت مشهورة والله ….الله يوفقك يا رب

  25. السلام عليكم
    عندي مودم ثومسون TG585 اصدار 8
    حبيت احجب موقع يوتيوب عن الاطفال وعند الدخول على اليوتيوب عن طريق الأيباد او الأيبود تبع أطفالي اريد تحويلهم الا موقع اخر مثل موقع اسلام او موقع مختص للاطفال مثلا

    فكيف يمكنني ان اعدل او اغير في الاعدادات بحيث استطيع انا ادخل ولكن احجب عن الاطفال !

  26. الله يعطيك ألف عافية أستاذ أيمن ..هي الطريقة فعالة وحلوة بس مو موثوقة لأنو فينا نخترقها بكل سهولة عن طريق https وما عنا امكانية تحديد صلاحيات لليوزر يعني بهيك طريقة بسكر اليوتيوب عند الجيمع او بيفتح عند الجيمع اذا لغينا هل الامر هل يوجد طريقة لتحديد صلاحيات لليوزر بحيث يستطيع استخدام ال youtub واغلاق الموقع على باقي الاجهزة ؟ وشكرا كتير على مقالاتك الاكثر من رائعة

  27. حضرتك انا عندى راوتر D Link DSL 2730 U WiFi

    وعاوز احجب موقع اليوتيوب على الشبكة الى على الراوتر

    المهم انى دخلت على

    advanced setup

    وبعدين url address

    وكتبت http://www.youtube.com
    وبرضه مش اتقفل

    وكتبته بطريقه تانيه زى youtube.com

    برضه مش اتقفل

    وكتبته ب youtube

    برضه مش اتقفل

    مع العلم انا قافل بنفس الطريقه مواقع تانيه

    عاوز اعرف ازاى اقفل اليوتيوب على الراوتر

  28. افضل طريقة للحجب وعن تجربة هو استعمال برنامج Kerio سواء ويندوز سرفر او لينكس

  29. السلام عليكم
    معلومات قيمة .
    بش مهندس طيب في حين اردت ان الغي الحظر ؟
    هل اكتفي بكلمة NO أمام كل امر ؟ فقط

أضف رد على Mohammed Alsharabi إلغاء الرد

لن يتم نشر البريد الإلكتروني . الحقول المطلوبة مشار لها بـ *

*

x

‎قد يُعجبك أيضاً

حل مشكلة error 27850 عند تنصيب Cisco VPN Client

مقال سريع لتوثيق مشكلة صادفتني وقمت بحلها بخطوتان وهي تنصيب برنامج سيسكو الخاص بالـ VPN ...

مقارنة بين أنظمة سيسكو IOS و IOS-XR و IOS-XE و NX-OS

في هذا المقال سوف نتعرف سوياً على جميع الأنظمة التشغيلية التى قامت سيسكو بتطويرها وهي ...

كيف أتحكم في الباندويث الخاص بالشبكة ؟

من ملاحظتي لكلمات البحث التى تصل من غوغل إلى المدونة وجدت أن الكثير من النتائج ...